electronic problem left hand signal light and horn

Go down

electronic problem left hand signal light and horn

Post by Scott Leier on Sat Jul 12, 2008 9:25 am

For some reason my left hand signal light and horn have stopped working. I have checked the fuse and taken apart the signal switch and horn switch and have run a test on them and they seem to be working. It appears that they use a common lead for power. I have taken it to the local bike shop Valley Yamaha but they were unable to assist. Any suggestions.
Scott

Scott Leier

Number of posts : 54
Location : Port Williams, NS
Registration date : 2008-07-12

View user profile

Back to top Go down

signal / horn problem

Post by Chris on Sat Jul 12, 2008 7:28 pm

If the rear signal on the same side works, I would check to see if the signal and horn share a common ground and check that. Run a separate wire to a good ground as a quick test.
Chris

Chris

Number of posts : 11
Location : Southshore
Registration date : 2008-04-10

View user profile

Back to top Go down

Re: electronic problem left hand signal light and horn

Post by Scott Leier on Sat Jul 12, 2008 7:43 pm

Neither front or back light come on with the signal switch but all four come on with the 4 way flasher Button is pushed. There is a common wire that both switches when engaged use, Would this be the common ground? Or would it be the positive?

Scott Leier

Number of posts : 54
Location : Port Williams, NS
Registration date : 2008-07-12

View user profile

Back to top Go down

Re: electronic problem left hand signal light and horn

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum